You must Sign-in or Register to post messages in the Hobby Squawk community
Registration is FREE and only takes a few moments

Register now

Announcement

Collapse
No announcement yet.

E-Flite UMX Aero Commander

Collapse
X
Collapse
First Prev Next Last
  • Filter
  • Time
  • Show
Clear All
new posts

  • E-Flite UMX Aero Commander

    The UMX Aero Commander arrived this afternoon and my daughter and I were pumped! First impression...the dang box is BIG!!

    We immediately opened it up with camera in hand and were blown away. I put two flights on it with two 7.4V 850mAh Graphene packs. With mixed throttle I flew for approximately 6 1/2 minutes and had approximately 45% remain...though I was in the power a bunch! One word...AWESOME!!!

    The model is having one issue with the elevator servo moving uncommanded/jumping on the ground and in the air about every minute or so. I still flew it and will get with Horizon to see if this can be done to resolve the issue.

    Outstanding job by the Horizon Team. Bob Hoover would be proud!

    Flight videos uploading now.

  • #2
    Maiden video
     

    Comment


    • #3
      Very, very cool! Thanks for posting this, Tony. I'm sure Horizon will hammer out that bug for you. Looking forward to seeing this one more often. Bob Hoover deserves the best!

      Comment


      • #4
        Thanks Linda & Alpha! It's so much fun to fly.

        Definitely a receiver issue. Ailerons and rudder/steering were glitching as well. I'll contact Horizon Customer Service later today.

        Here's another fun video of the second flight.
         

        Comment


        • #5
          Wow that thing has some punch! And impressive flight time

          Comment


          • #6
            Oh yeah....it scoots right along! UMX Aero Commander is my new favorite micro.

            Comment


            • #7
              Contacted Horizon, they are sending a return shipping label and will credit the cost of the model once it arrives. I have a new Aero Commander on the way. All good!

              Comment


              • #8
                Sweet!

                Comment


                • #9
                  Pre ordered mine at Motion, I'm guessing I'll get a shipping notice any day now. :)

                  Comment


                  • #10
                    You'll love it!

                    Comment


                    • #11
                      Xplaneguy, do you recall if the elev travel looked weak?

                      i have the travel set to 97%, rod in the proper control horn hole, and I'm getting 2-3mm travel. It doesn't look right.

                      Any help appreciated.

                      Comment


                      • #12
                        I love my Aero Commander. I was dumb and ripped out the nose gear assembly trying to pull the gear out but it buffed out with some glue. I also ended up making a support out of cardboard for that linkage so it wouldnt bind when turning the nose gear. This thing is a blast to fly without gear and belly land on grass. I'm still new to flying so i just applied packing tape to help ease the fuselage during landings. flight time was around 9 minutes but i was in 80-95% throttle due to wind.

                        Comment


                        • #13
                          Originally posted by grant22 View Post
                          Xplaneguy, do you recall if the elev travel looked weak?

                          i have the travel set to 97%, rod in the proper control horn hole, and I'm getting 2-3mm travel. It doesn't look right.

                          Any help appreciated.
                          Mine is set up stock with 100% travel, no issues...plenty of elevator authority! Recommend a short test hop to see if you have enough elevator, 2-3mm full deflection seems like a small amount.

                          Comment


                          • #14
                            Just got mine today. Dead/intermittent rudder servo out of the box. Gotta call Horizon tomorrow. Ugh...

                            Comment


                            • #15
                              I just ordered my FOURTH one of these. I waited several months to see if these Aero Commanders have gotten any better. As I said above, the first one had a dead rudder channel. Got a replacement and had servo glitching. I tried to fly it and it glitched itself into the ground after about a minute. Got another replacement and it had the same servo glitching during a bench run-up. Returned that one without even trying to fly it despite people saying on RCGroups that they didn't notice it in flight. That was all back in February. Hopefully, this FOURTH one will be good because I really, really want a nice little Aero Commander!

                              And, no, it's not my TX as Horizon accused. I fly everything else (planes, helis, quads, weird VTOL things) off the same TX with zero issues. The last one (the third one) I had did the same thing with servo glitching on my main DX9 Black, my backup DX9 silver and my old original Gen 1 DX8. It's NOT the radios.

                              Comment


                              • #16
                                Servo problem could be caused by the push rod binding in the guide. The guides are veryvsamll and it is easy to get glue in the guide during manufacturing

                                Comment


                                • #17
                                  Gave mine a make over thanks to Callie. I did have the rudder servo go out, or locked up. Bought a replacement, just havent swapped it out yet.

                                  Comment


                                  • #18
                                    That a nice looking Bob Hoover finish. Glad to see the crappy rudder servo didn't cause it to burn in.

                                    Comment


                                    • #19
                                      No, it fried on the workbench. Ill eventually get around to splitting it open and swapping it out.

                                      Comment

                                      Working...
                                      X