2000mm Giant Scale B-24 - Olive Drab

You must Sign-in or Register to post messages in the Hobby Squawk community
Registration is FREE and only takes a few moments

Register now

Announcement

Collapse
No announcement yet.

Official FlightLine OV-10 Bronco Discussion Thread

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Helmsman52
    replied
    Has anyone converted this to run off one 6s lipo like the fms Tigercat yet? Thanks.

    Leave a comment:


  • Gosche
    replied
    Thanks a lot, all clear :-)

    Leave a comment:


  • xviper
    replied
    Originally posted by Evan D View Post
    The aileron goes through the multiconnector so that would defeat the purpose.
    ^ This. If you are real good with hunting down the correct wires from that multiconnector for the AIL, you can remove them and solder your own 3-pin connectors and "Y" them directly to the RX. It's risky business as these multiconnectors use common grounds for multiple servos. A lot of really bad things can happen if you make a slight "boo-boo".

    Leave a comment:


  • Evan D
    replied
    The aileron goes through the multiconnector so that would defeat the purpose. Along with the ailerons the outer flaps and lights go through it. You can bypass everything else, rudders, retracts, motors, etc.

    Leave a comment:


  • Gosche
    replied
    Originally posted by xviper View Post
    I have never trusted these "blue boxes" since the early days of them coming into service. I've had a couple of crashes due to them. My OV10, along with almost all of my planes that have these boxes, have had the critical control surfaces by-passing the box - AIL, ELE. I don't bother with the other servos. If any of them fail, I can still "bank and yank" the thing back.
    Have a question Sir. Can you bypass the blu-box for AIL, ELE and still benefit from the multi connector in the outer wing (taking the wing off for easy transport/storage) ?
    I have not bought the OV-10 Bronco yet, but am seriously considering it.
    Thanks in advance

    Leave a comment:


  • Mad Baron
    replied
    Got it. Thanks for the info now I can see the telemetry!

    Leave a comment:


  • xviper
    replied
    There's nothing to set up on the RX. It's already sending stuff to the TX. You have to tell the TX to show it. You need to see what's in the "flight log".

    Leave a comment:


  • Mad Baron
    replied
    I do have a telemetry ready RX but l don't know how to set it up. I have a Spektrum NX8.

    Leave a comment:


  • xviper
    replied
    Originally posted by Mad Baron View Post
    I think I will bypass the blue box Aileron and Elevator as well. I don't want a repeat of what happened last time I flew it.
    Another thing to consider is momentary loss of signal. Do you have a RX with telemetry? It will tell you the number of frame losses and holds during the flight.

    Leave a comment:


  • Evan D
    replied
    I agree, while I don’t not trust them I either remove them or just leave retracts and lights through them… I do it more to get more programming with higher channel count receivers.

    Leave a comment:


  • Mad Baron
    replied
    I think I will bypass the blue box Aileron and Elevator as well. I don't want a repeat of what happened last time I flew it.

    Leave a comment:


  • xviper
    replied
    Originally posted by Mad Baron View Post
    Has anyone had any problems with the blue box? I had my OV10 go out of control for no reason at all I was able to get control of the plane but it landed pretty hard and broke the nose gear. When I replaced the gear the connector in the blue box was loose.
    I have never trusted these "blue boxes" since the early days of them coming into service. I've had a couple of crashes due to them. My OV10, along with almost all of my planes that have these boxes, have had the critical control surfaces by-passing the box - AIL, ELE. I don't bother with the other servos. If any of them fail, I can still "bank and yank" the thing back.

    Leave a comment:


  • Mad Baron
    replied
    Has anyone had any problems with the blue box? I had my OV10 go out of control for no reason at all I was able to get control of the plane but it landed pretty hard and broke the nose gear. When I replaced the gear the connector in the blue box was loose.

    Leave a comment:


  • xviper
    replied
    Originally posted by Quoll View Post
    Hey everyone,

    Just doing a makeover on my recently arrived OV10. An impressive model but I found the screws into the wing centre section into the booms appear too short. As a result the centre section raises up. Before I remove those screws and attempt to use longer screws, has anyone had a similar issue. If so can you please advise your experience and how the fix went.

    I also had minor trouble with the rudder not working correctly and traced that to a defective lead.

    Thanks
    I don't think it's that the screws are too short. I think you're missing the hole. IE, the alignment is off. However, I could be wrong. Next time you push the wing section into the boom section, have the plane upside down so you can see the slot of the wing section as it slides onto the peg of the boom. Does it go in far enough to align the path the screw must go to get threaded and seated? If the alignment is off just a little, the screw will be pushing up against the peg, thereby shoving the boom section up as the wing section is forced down.
    PS. If you don't have ALL the wires shoved into the space in the boom section, a single wire hanging in the space between the wing section and boom section will prevent the wing section from mating flush with the boom. That gap is enough to misalign the hole.

    Leave a comment:


  • sam51401
    replied
    Ill post a pic but i use a S6R with my Horus for a yaw dampner and she flies so sweet. When the wind is calm , the stabilization isnt needed. I actually have installed into th eside of the fus right above the rear of the batteries.

    Leave a comment:


  • sam51401
    replied
    Im not seeing what you mean that the wing to boom screws are too short and yet you mention the wing center section rises up. First i have heard of this and like to help. Pics of this will help.

    Leave a comment:


  • Evan D
    replied
    Receiver back in the back fuselage, no gyro.

    Leave a comment:


  • Abwagner121
    replied
    Where is everyone putting their receivers/gyros? Can I see some pics please,

    Leave a comment:


  • Quoll
    replied
    Hey everyone,

    Just doing a makeover on my recently arrived OV10. An impressive model but I found the screws into the wing centre section into the booms appear too short. As a result the centre section raises up. Before I remove those screws and attempt to use longer screws, has anyone had a similar issue. If so can you please advise your experience and how the fix went.

    I also had minor trouble with the rudder not working correctly and traced that to a defective lead.

    Thanks

    Leave a comment:


  • Cobra1365
    replied
    Originally posted by SanExup View Post
    Cobra1365 I hope that helps solve the gear issue as well. Nice Shelby Cobra!!!
    Thanks!

    Yeah, it’s a nice toy! 😉

    Leave a comment:

Working...
X