Roban - World Class Scale Helicopters

You must Sign-in or Register to post messages in the Hobby Squawk community
Registration is FREE and only takes a few moments

Register now


No announcement yet.

Blade nano s2 Shooting up in 3d mode

First Prev Next Last
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blade nano s2 Shooting up in 3d mode

    Hi Guys,
    I have blade nano s2 and DX8G2 transmitter
    all my hovering skills are quite good in sports flying mode. now as soon as i go in 3D mode (stunt 2 on my spektrum DX8G2), the S2 goes flying high on the ceiling non stop! these are the settings as per the manual that came with it. see attached. is there anything wrong in it? in the 3D why does it sky rocket!? the pitch is not controllable. and since its always going up i can;t even hover in 3D mode. and if i cant hover, i cant do a 3D flip even!
    can you shed some light on this?

    the 3D stunt mode throttle curve is set to all positive 100 for all 5 points and pitch curve is set at 0,25,50,75,100. is these settings correct? why does my heli shoot to the ceiling even when the throttle stick is at mid point!

    Thanks in advance

  • #2
    Just got one earlier this week and been looking for forums on it. Someone posted in RCGROUP that you need to put throttle cut to same switch as throttle hold. Should be sending -130 on throttle. In 3D mode all throttle settings are ignored and ran at 100%. It even ignores throttle hold. Throttle cut is needed to stop the motor in 3D mode on the S2. I don't understand what that person posted cause I'm using the TX that came with the RTF. But, I'm thinking about binding it to my dx6 because I read that when you bind to a computerized TX you get 3 flight modes. With the RTF you get throttle hold, beginner CP, and 3D. I heard with computerized TX you get coaxial, beginner CP, and 3D.


    • #3
      ok i kind of figured out the issue is, when i put in 3D mode, the servo arm does not move all the way down when i give negative pitch! it still stays up which means it always is on a positive pitch, thus no matter what i do, the heli goes all the way to the ceiling! never comes down. this only happens in 3D mode. sport flying is perfectly fine. can anyone tell us what settings to check for this not to happen??


      • #4
        Will changing the throttle to - 130 help? I don't know too much about changing the settings.


        • #5
          i think i would try that! changing to -130 coz in HOLD mode my throttle is -130 and it goes all the way down...mmm..let me try that..any other suggestions would be great...thanks.