You must Sign-in or Register to post messages in the Hobby Squawk community
Registration is FREE and only takes a few moments

Register now

Announcement

Collapse
No announcement yet.

RX 600SP gyro issues

Collapse
X
Collapse
First Prev Next Last
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    I will get a picture of how mine is set up tonight and see if we can get to the bottom of this...
    we’ll get you set up.

    Comment


    • #22
      When I put the reciever into
      Combo B: Gyro Off / Recovery. LED “Pattern” = Red and Green displayed together for two seconds

      Gyro is still always on, after removing the bind plugs solid green light. Gyro should be off.

      I believe this indicates receiver is not operating correctly.

      Comment


      • #23
        Click image for larger version

Name:	9ABD6AAE-3883-4BDA-A10A-078D8111DF04.jpeg
Views:	59
Size:	194.6 KB
ID:	193548 I just realized the videos on UToob are not the ones with Ryan and Mike...

        My plane is set up for Combo C, and truth be told, I seldom use the gyro but it does work well. I found I get the same results with a low rate at 70% and an expo of 20%. When I use the gyro I put it into high rates and expo off. Been awhile since I set it up so I was wrong about the SWITCH setting...yours is ok as mine is same.

        Comment


        • #24
          The problem with my RX600SP happens regardless of rate or expo setting.
          as indicated I’m my previous post the receiver responds incorrectly regardless of any radio connection.

          https://www.hobbysquawk.com/forum/el...541#post193541

          I have a ticket open with product support and they are looking into the issue.

          Thanks for you help in trying to resolve the issue..

          K

          Comment


          • #25
            Can this receiver cause severe oscillation(rapidly swaying left to right)? That's what happened on my maiden today. Ended up crashing.

            Comment


            • #26
              Originally posted by Coconut View Post
              Can this receiver cause severe oscillation(rapidly swaying left to right)? That's what happened on my maiden today. Ended up crashing.
              had the gain set to high, back off the throttle will stop it.

              Comment


              • #27
                Thank you. I didn't even check the gains. Left it the way it came from the factory. It's all my fault. Lesson learned.

                How do you check the gains? I think I will have to get a new Lippisch even though there was minimal damage(fingertip lenght broken off one side of the wing and aileron). I was surprise that it didn't even nose dive into the ground. I couldn't find that piece that broke off.

                Comment


                • #28
                  you adjust the gain by the 3 pots (white circle with the slot, that a flat head fits in too)

                  Comment

                  Working...
                  X